WordPressにプラグインWP Security Scan 2.3をインストール

WordPressにプラグインWP Security Scan 2.3をインストールしてみた。
指摘された問題点は、

  • Your table prefix should not be wp_
  • “admin” user exists
  • The file .htaccess does not exist in wp-admin/

の3つ。
“admin”アカウントは普段使っているのだが、管理画面を見ると

ユーザー名は変更できません。

ということなので、気にしないことにする。
wp-admin/.htaccessは作っておく。
WP Security Scanには、table prefixを変更する機能があるが、

Make a backup of your database before using this tool

ということなので、WordPressにプラグインWP-DBManager 2.31をインストールでインストールしたWP-DBManagerで、毎週のバックアップとは別に手動でバックアップしておく。
その後、「Security」の「Database」で別のprefixを入力して、「Start Renaming」をクリックしたが、

Your User which is used to access your WordPress Tables/Database, hasn’t enough rights( is missing ALTER-right) to alter your Tablestructure. Please visit the plugin documentation for more information. If you believe you have alter rights, please contact the plugin author for assistance.

ということだったので、今日はあきらめることにする。

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク